Русская сборка OpenCart 2.1.0.2 - Релиз

Тема в разделе "Новости и объявления", создана пользователем Romans, 13 янв 2016.

  1. Romans

    Romans Administrator Команда форума

    Сообщения:
    1.338
    Симпатии:
    698
    Рад сообщить Вам о выходе релиза OpenCart 2.1 - Русская сборка

    Релиз v 2.1.0.2 можно скачать по ссылке.
    Последняя версия сборки Version 2.1.0.2 (rs.1)
    Дата исправлений 13.01.2016

    Что же изменено по сравнению с оригинальной версией Opencart ?
    • Русский язык для витрины и административной части магазина
    • Русский редактор текста в административной части
    • Русские города и области на русском.
    • Все города и регионы стран не входящих в "СНГ" удалены.
    • Переведены все статусы склада, заказов, возвратов.
    • Скрыты поля (sku, isbm итд) в карточке товара (Панель администратора)
    • Оповещение администратора о заказе по СМС
    • Удалены способы доставки и оплаты не применяемые в РФ
    • Переделан seo_url.php и подправлен common.js на предмет корректной работы ЧПУ
    • Автогенерация SEO URL (ЧПУ)
    • Увеличена длина поля для хранения кода ocmod в БД
    • Почти все изменения выполнены с помощью ocmod (см. файл tweak.ocmod.xml)
    • Удалены файлы модулей не применяемых в России (~ 600 файлов)
    Удаленные файлы заархивированы в папку deleted-files
    Если есть желание восстановить удаленные файлы, то просто из указанной папки, копируйте все в корень сайта.

    Что нового по сравнению с предыдущим релизом 2.1.0.1 ?
    Ошибки
    Исправлены ошибки безопасности (XSS)

    ниже исправлено только в Русской сборке
    Ошибка неизвестной переменой на странице Импорта\Экспорта БД
    Сохранение лог файла на странице просмотра ошибок - некорректное название файла
    Невозможно сделать обновление с версии 2.0.3.1
    При оформлении заказа, если не выбрать согласия с условиями, кнопка блокируется
    Добавлены переносы строк в seo_url.php для большей совместимости

    Изменения
    Корректировки локализации (только в Русской сборке)
    Ротация пунктов меню в разделе Модули для удобной навигации (только в Русской сборке)

    Добавлено
    нет

    Информация для обновления
    Обновление с предыдущей версии (например 2.0.3.1) выполняется согласно документации по обновлению.
    Так же при обновлении с версий ниже .2.1 не забываем изменить файлы config.php и admin/config.php (что изменилось выделено жирным)

    define('DIR_CACHE', 'C:/OpenServer/domains/2101rc/system/storage/cache/');
    define('DIR_DOWNLOAD', 'C:/OpenServer/domains/2101rc/system/storage/download/');
    define('DIR_LOGS', 'C:/OpenServer/domains/2101rc/system/storage/logs/');
    define('DIR_MODIFICATION', 'C:/OpenServer/domains/2101rc/system/storage/modification/');
    define('DIR_UPLOAD', 'C:/OpenServer/domains/2101rc/system/storage/upload/');

    // DB
    define('DB_DRIVER', 'mysqli');
    define('DB_HOSTNAME', 'localhost');
    define('DB_USERNAME', 'root');
    define('DB_PASSWORD', '');
    define('DB_DATABASE', 'oc2101rc');
    define('DB_PORT', '3306');
    define('DB_PREFIX', 'oc_');


    Обновление с 2.1.0.1rs2 выполняется простой заменой файлов.
    Файлы замены приложены архивом upgrade-2101rs2-to-2102rs1.zip

    .


    В OpenCart 2 Русская сборка сохранена полная совместимость с модулями и темами от OpenCart 2

    Об ошибках данного релиза просьба писать в данной теме.

    Вопросы "как установить", "а как мне сделать" просьба задавать в другом разделе или теме форума.

    Инструкция по установке находится в разделе Документация

    P.S Всем хороших тестов и внедрений !!!
     

    Вложения:

    Последнее редактирование: 13 янв 2016
    Евгений, Zlata Jesen, noxio077 и 4 другим нравится это.
  2. RouiD

    RouiD Новичок

    Сообщения:
    1
    Симпатии:
    0
    Есть проблема с ReCAPTCHA. Когда гость оформляет заказ без регистрации, заполняет "Платежная информация" и нажимает "продолжить" - ничего не происходит. Там должна быть капча (с простой защитой она там есть), но ее там нет.
    Надеюсь пофиксите, а то приходится юзать простую защиту пока)
    PS. Проблема была и на 2.1.0.1 rs2 версии, я думал тут будет исправлено.
     
  3. Vlad

    Vlad Эксперт

    Сообщения:
    3.870
    Симпатии:
    936
    все так думали, но главные создатели не то что это не сделали, так не сделали еще и много другое, что уже сделано в сборке.

    Пока что вроде никому не нужно было так как все пользуются видимо сторонними модулями оформления заказа.
    Если еще кому то нужно, то думаю персонально для сборки подправят, там просто много править вроде надо...
     
  4. Валерик

    Валерик Пользователь

    Сообщения:
    97
    Симпатии:
    7
    Пришлось только переустановить модификаторы
     
  5. shutle

    shutle Новичок

    Сообщения:
    3
    Симпатии:
    0
    Здравствуйте, нужен мне SKU в админке, как его отобразить
     
  6. Ravilr

    Ravilr Специалист

    Сообщения:
    3.108
    Симпатии:
    860
    нажать на кнопку рядом с Моделью !!!
     
    shutle нравится это.
  7. solunski.d

    solunski.d Эксперт

    Сообщения:
    1.565
    Симпатии:
    428
    @Roman, я нашел ошибку в релизе, и в официальном так же.
    Ошибка появляться в баннере, при создании нового блока для изображения
    этот код из админки, banner_form.tpl
    PHP:
    html += '  <td class="text-right" style="width: 10%;><input type="text" name="banner_image[' + image_row + '][sort_order]" value="" placeholder="<?php echo $entry_sort_order?>" class="form-control" /></td>';
    Если присмотреться, то видно что атрибут style не закрыт, добавь ". Кстати как называется символ по русски, а то я забыл? :D
     
    Последнее редактирование: 3 фев 2016
  8. Vlad

    Vlad Эксперт

    Сообщения:
    3.870
    Симпатии:
    936
    а есть ли ошибка??? Посмотри в tweak.ocmod.xml и в конце увидеш!!
     
  9. solunski.d

    solunski.d Эксперт

    Сообщения:
    1.565
    Симпатии:
    428
    Понял, ошибка в официальном... :D
     
    Последнее редактирование: 3 фев 2016
  10. Ved

    Ved Новичок

    Сообщения:
    7
    Симпатии:
    0
    Появилась проблема при наполнении, главная категория не выбирается. А в предыдущем товаре выбралась. Как можно этот вопрос решить?

    Спасибо за внимание!
     
  11. Ved

    Ved Новичок

    Сообщения:
    7
    Симпатии:
    0
    Разрешилось, после рестарта денвера, а еще кеш чистил. Но наверное мало вероятно что кеш виноват.
     
  12. Ryv

    Ryv Новичок

    Сообщения:
    18
    Симпатии:
    2
    Господа, вот эту ситуацию прокомментировать кто-то сможет?
    "Исправлены ошибки безопасности (XSS)".

    Что, где и в каких файлах поменять кто-то знает конкретно? Как-то обновляться желанием не горю с предыдущей версии.
     
  13. Romans

    Romans Administrator Команда форума

    Сообщения:
    1.338
    Симпатии:
    698
     
  14. vas13

    vas13 Новичок

    Сообщения:
    3
    Симпатии:
    0
    Всем привет!
    После установки релиза Русская сборка OpenCart 2.1.0.2
    Вылезли следующие "непонятки" :

    1. Int Exp 8 показал следующие ошибки:

    Сведения об ошибке на веб-странице
    Агент пользователя: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C; .NET4.0E)
    штамп времени: Tue, 16 Feb 2016 08:36:52 UTC

    Сообщение: Объект не поддерживает это свойство или метод
    Строка: 2
    Символ: 29694
    Код: 0
    URI-код: http://isk-magazin.ru/catalog/view/javascript/jquery/jquery-2.1.1.min.js

    Сообщение: Bootstrap's JavaScript requires jQuery
    Строка: 6
    Символ: 31
    Код: 0
    URI-код: http://isk-magazin.ru/catalog/view/javascript/bootstrap/js/bootstrap.min.js

    Сообщение: Предполагается наличие объекта
    Строка: 35
    Символ: 1
    Код: 0
    URI-код: http://isk-magazin.ru/catalog/view/javascript/common.js

    Сообщение: 'jQuery' - определение отсутствует
    Строка: 1
    Символ: 1
    Код: 0
    URI-код: http://isk-magazin.ru/catalog/view/javascript/jquery/owl-carousel/owl.carousel.min.js

    Сообщение: Предполагается наличие объекта
    Строка: 160
    Символ: 1
    Код: 0
    URI-код: http://isk-magazin.ru/

    Сообщение: Предполагается наличие объекта
    Строка: 280
    Символ: 1
    Код: 0
    URI-код: http://isk-magazin.ru/

    Так же в этом же браузере отображается сайт некорректно

    2. Не отправляются сообщения (обратная связь) админу
    3. Не отправляются на почту подтверждение заказа не админу не покупателю.

    Хостинг: Джино, на Joomle все отправляется.

    Вопрос как решить данные вопросы, уже голову сломал :(
     

    Вложения:

    • ош 8.jpg
      ош 8.jpg
      Размер файла:
      78,8 КБ
      Просмотров:
      20
    • сайт.jpg
      сайт.jpg
      Размер файла:
      62,2 КБ
      Просмотров:
      20
  15. Ален

    Ален Эксперт

    Сообщения:
    2.055
    Симпатии:
    634
    ИЕ8 не поддерживается системой! Работь корректно в устаревшем браузере не будет

    поиск по форуму поможет. Сто раз обсуждалось и к работе данного релиза никак не относится.
     
  16. vas13

    vas13 Новичок

    Сообщения:
    3
    Симпатии:
    0
    Жаль что ИЕ8 не поддерживает, еще многие его используют например с Win XP
    Спасибо за оперативный ответ.
     
  17. vas13

    vas13 Новичок

    Сообщения:
    3
    Симпатии:
    0
    Проблема получением e-mail и сообщений устранена, оказалось что хост отключил функцию mail.
     
  18. solunski.d

    solunski.d Эксперт

    Сообщения:
    1.565
    Симпатии:
    428
    :D @vas13 забудь ты про IE8, в марте он прекратится поддерживаться официально, а возможно и 9 тоже.
    Смысл поддерживать хлам. Это не наша проблема что мы не сделали сайт под IE8, это проблема пользователя, что у него мозгов не хватает позаботится и обновиться.
    Идиоты используют. Создайте блок в котором им скажут что "вы используете старый браузер и для их ней безопасности нужно обновиться иначе могут быть последствия. И указать ссылки на популярные браузеры. Все. Так же для тех у кого ума хватило отключить JS, для таких идиотов создается подобное
     
    Последнее редактирование: 16 фев 2016
  19. Ryv

    Ryv Новичок

    Сообщения:
    18
    Симпатии:
    2
    А есть информация для каких версий OC актуальна данная XSS? Я спрашиваю с той целью, что у меня, например, еще 2.0 ветка. Все-таки, если есть информация, хотелось бы узнать что за функционал затронут.
     
  20. Vlad

    Vlad Эксперт

    Сообщения:
    3.870
    Симпатии:
    936
    все 2х.

    регистрация, авторизация