Поиск не работает при включенном SEO

Тема в разделе "Ошибки и их решения", создана пользователем serg96, 6 дек 2014.

  1. serg96

    serg96 Новичок

    Сообщения:
    4
    Симпатии:
    2
    Параметр search просто не учитывается. Редиректит с
    /index.php?route=product/search&search=123
    на
    /search
     
  2. Romans

    Romans Administrator Команда форума

    Сообщения:
    1.339
    Симпатии:
    698
    спасибо. Разберусь.
     
  3. Romans

    Romans Administrator Команда форума

    Сообщения:
    1.339
    Симпатии:
    698
    Замените файл в папке catalog/controller/common/

    Я доработал сео.
    Если не сложно, проверьте в разных вариантах.
    Самая главное это редиректы со старых ссылок типа index.php?route=information/information&information_id=4
    для статей, товаров, категорий итд
     

    Вложения:

    • seo_url.zip
      Размер файла:
      1,5 КБ
      Просмотров:
      71
    Последнее редактирование: 6 дек 2014
    Aliaz и Илья нравится это.
  4. Sadovod

    Sadovod Новичок

    Сообщения:
    1
    Симпатии:
    0
    у кого поиск заработал?Я файл заменил,но как перекидывало на страницу поиска с нулевым результатом так и перекидывает.А вот поиск со страницы поиска работает нормально.
     
  5. Ravilr

    Ravilr Специалист

    Сообщения:
    3.156
    Симпатии:
    873
    у всех. Решение выше это для определенной версии в определенный момент времени.

    Чтобы заработал поиск нужно знать максимум информации от адреса сайта, до его версии, модулей, модификаторов итд..