Не получается установить opencart 3.0.2.0

Тема в разделе "Установка и обновление", создана пользователем dsilver, 3 май 2023.

  1. dsilver

    dsilver Новичок

    Сообщения:
    6
    Симпатии:
    0
    Здравствуйте,
    Не как не могу установить opencart 3.0.2.0. После ввода данных БД, логина и пароля и перехода на 4 шаг выдает ошибку
    Страница недоступна Сайт (мой домен) пока не может обработать этот запрос.
    HTTP ERROR 500

    При том что версия opencart 4.0.2.1 без проблем устанавливается. Может кто сталкивался, в чем может быть проблема?

    P.S Устанавливаю на домашний сервак, на котором стоит fastpanel

    Заранее благодарю!
     
  2. zema50

    zema50 Продвинутый пользователь

    Сообщения:
    863
    Симпатии:
    98
    на какую версию рнр ставите ?
     
  3. Tom

    Tom Специалист

    Сообщения:
    740
    Симпатии:
    239
    Причин много.
    Например версия php.
    Какие то "хвосты" от прежних установок.
    итп
     
  4. dsilver

    dsilver Новичок

    Сообщения:
    6
    Симпатии:
    0
    Версия php 7.4
     
  5. dsilver

    dsilver Новичок

    Сообщения:
    6
    Симпатии:
    0
    Версия 7.4. Все начисто удалял, могу даже домен новый привязать все тоже самое
     
  6. Tom

    Tom Специалист

    Сообщения:
    740
    Симпатии:
    239
    Как вариант, попробуйте вывести ошибку на экран, но перед этим снизьте версию php до 7.1
    Ваша версия опенкарт не поддерживает её.
    Для вывода ошибок в конец файла htaccess добавьте
    php_flag display_startup_errors on
    php_flag display_errors on
    php_flag html_errors on
    php_flag output_buffering off

    Или в файл index.php
    Сразу после
    <?php
    с новой строки
    ini_set('error_reporting', E_ALL);
    ini_set('display_errors', 1);
    ini_set('display_startup_errors', 1);
     
  7. dsilver

    dsilver Новичок

    Сообщения:
    6
    Симпатии:
    0
    Ошибки не выводит, после нажатия продолжить показывает вот эту страницу
    opencart2.png
    [​IMG]
     
  8. Tom

    Tom Специалист

    Сообщения:
    740
    Симпатии:
    239
    Попробуйте всё удалить и установить более свежую версию 3.0.3.7-3.0.3.8
    Здесь ещё и в вашем "домашнем серваке" может быть причина.
     
  9. dsilver

    dsilver Новичок

    Сообщения:
    6
    Симпатии:
    0
    Я бы мог на сервак подумал, но opencart 4.0.2.1 без проблем устанавливается. Сейчас попробую версию 3.0.3.7-3.0.3.8
     
  10. Tom

    Tom Специалист

    Сообщения:
    740
    Симпатии:
    239
    Ну и на всякий, всё же проверьте что бы всё было удалено. Включая папку storage вне папки магазина.
     
  11. dsilver

    dsilver Новичок

    Сообщения:
    6
    Симпатии:
    0
    Понял, благодарю за помощь
     
  12. zema50

    zema50 Продвинутый пользователь

    Сообщения:
    863
    Симпатии:
    98
    1 смотрите лог ошибок system/storage/logs/error.log
    2. если там нет нечего, создайте в корне папку tmp, в ней файл php-error.log, в index.php пропишите сразу ниже <?
    вот это
    ini_set("log_errors", 1);
    ini_set("error_log", dirname(__FILE__)."/tmp/php-error.log");
    error_reporting(E_ALL);

    в файле php-error.log должно показать ошибки
    вообще то не советую, она есть кривая, ставьте на 7.2 или 7.3