Как убрать PHP Notice из лога?

Тема в разделе "Общие вопросы", создана пользователем iron-zorin, 19 авг 2024.

  1. Tesloz

    Tesloz Специалист

    Сообщения:
    140
    Симпатии:
    70
    Так он знает как исправить: Писать на каждой строчке isset - желания нет.
    Просто наверное каждый раз в разных переменных этого добавлять не хочет, либо клиент "сказал" именно Отключить!
    90% что клиента)) (если это не ваш профиль, то извиняюсь)
    Вообщем ваш ответ для 2-ки в handler:
    admin/controller/startup/error.php
    catalog/controller/startup/error.php
    Сами можете модификатор сделать, там просто, надеюсь разберётесь :)
     
    Последнее редактирование: 20 авг 2024
    iron-zorin нравится это.
  2. Tom

    Tom Специалист

    Сообщения:
    1.051
    Симпатии:
    386
    Андрей. Возможно что любые ответы, которые вам лишний раз доказывают что вы взялись не за своё дело, раздражают вас исключительно по причине не особого желания выполнять свою работу на все сто.
     
  3. iron-zorin

    iron-zorin Пользователь

    Сообщения:
    50
    Симпатии:
    1
    А вот тут занятно. Именно в эту секунду ничего нет. Но секундой раньше - http://yandex.com/bots
    И ручное открытие этого урл - ошибок не выдаёт
     
  4. iron-zorin

    iron-zorin Пользователь

    Сообщения:
    50
    Симпатии:
    1
    Одно другому не мешает - наоборот :)
     
  5. iron-zorin

    iron-zorin Пользователь

    Сообщения:
    50
    Симпатии:
    1
    Вот за это - спасибо

    А в startup.php на третьей строчке error_reporting(E_ALL) - это для чего?
     
  6. Blast

    Blast Продвинутый пользователь

    Сообщения:
    269
    Симпатии:
    92
    секундой раньше это нормально.
    а вы открывали url http://yandex.com/bots ? это не ваш url. в этой же строке(или соседних) должен быть ваш адрес без доменного имени
     
    iron-zorin нравится это.
  7. iron-zorin

    iron-zorin Пользователь

    Сообщения:
    50
    Симпатии:
    1
    Нет конечно.
    87.250.224.34 - - [20/Aug/2024:10:00:43 +0300] "GET /search/ HTTP/1.1" 200 32560 "-" "Mozilla/5.0 (compatible; YandexBot/3.0; +http://yandex.com/bots)"
    Открывал /search/
    Но мне кажется, что провайдер в лог не всё пишет. Вряд ли Яндекс бот всего несколько страниц открывает
     
  8. iron-zorin

    iron-zorin Пользователь

    Сообщения:
    50
    Симпатии:
    1
    И чтобы два раза не вставать
    Время в логе вперемешку UTC и UTC+3
    Это как-то можно поправить?
     
  9. Blast

    Blast Продвинутый пользователь

    Сообщения:
    269
    Симпатии:
    92
    возможно у вас кэшируются данные и в данный момент в кэше находится корректная информация, поэтому ошибок и не возникает снова