Сразу после установки Доступ запрещен!

Тема в разделе "Установка и обновление", создана пользователем Webtehnikk, 11 фев 2016.

  1. Webtehnikk

    Webtehnikk Пользователь

    Сообщения:
    54
    Симпатии:
    1
    Всем доброго дня, сегодня поставил ещё раз опенкарт, всё вроде прошло успешно всё встало, но после установки абсолютно во всех пунктах админпанели надпись Доступ запрещен!
    Переустановил уже 3 раза эффекта нет. Опенкарт взята отсюда Version 2.1.0.2 (rs.1).
     

    Вложения:

  2. Zhezkazganetcs

    Zhezkazganetcs Продвинутый пользователь

    Сообщения:
    819
    Симпатии:
    107
    нужно группе администратор все права дать/все галочки поставить
     
  3. Webtehnikk

    Webtehnikk Пользователь

    Сообщения:
    54
    Симпатии:
    1
    Где это сделать то? в админке ко всем пунктам Доступ запрещен! и там где галочки ставить тоже запрещён.
     
  4. Zhezkazganetcs

    Zhezkazganetcs Продвинутый пользователь

    Сообщения:
    819
    Симпатии:
    107
    надеюсь кэш чистили?
    в режиме инкогнито заходили?

    я сам не опенсервере устанавливал десятки раз и такого не было
    вероятнее проблема у вас на компе
     
  5. Webtehnikk

    Webtehnikk Пользователь

    Сообщения:
    54
    Симпатии:
    1
    Чё только не делал, боюсь проблемы в БД, хотя все права открыты, на запись чтение и управление таблицами
     
  6. Zhezkazganetcs

    Zhezkazganetcs Продвинутый пользователь

    Сообщения:
    819
    Симпатии:
    107
    если сразу после установки доступ запрещен, то ищите траблу у себя
    опять же
    куда поставили? на хостинг? а база данных откуда?
     
  7. Webtehnikk

    Webtehnikk Пользователь

    Сообщения:
    54
    Симпатии:
    1
    Написал хостеру, говорят на ихней стороне праблы, жду....
     
  8. Webtehnikk

    Webtehnikk Пользователь

    Сообщения:
    54
    Симпатии:
    1
    всё заработало, на хостинге изменил версию PHP с 5,3 на 5,6
     
    Vlad нравится это.
  9. lionio

    lionio Новичок

    Сообщения:
    7
    Симпатии:
    0
    У меня такая же проблема.

    Хостинг steadyhost, версия PHP стоит 5,5
    OpenCart Version 2.0.3.1 (rs.2)

    Установил 2 модуля новостей через Ocmod:
    Blog system for OpenCart 2 и Модуль Новости в Opencart 2.0

    После установки обоих обнаружил 2 проблемы:
    1) В админпанели ДОСТУП ЗАПРЕЩЕН при нажатии на пункты меню этих модулей
    2) Новые модули не отображаются в разделе Модули -> Модули

    Гуглил - но там в основном все говорят, что нужно права поставить для Группы пользователей.
    Галочки все снимал и ставил - не помогает!
    Кстати, еще один нюанс, в Группе пользователей в полях "Разрешён просмотр" и "Разрешено внесение изменений" я не нашел этих модулей.

    Чистил папку cache, Модификаторы обновлял до и после установки (в модификаторах эти модули появились, якобы корректно установлены) - не помогло ничего.

    В PhpMyAdmin в таблице user_group ничего не понятно. Стоят какие-то значения:
    a:2:{s:6:"access";a:155:{i:0;s:17:"catalog/attribute";i:1;s:23:"catalog/attribute_group";i:2;s:16: и т.д...

    Что еще посоветуете сделать?
     
    Последнее редактирование: 13 май 2016
  10. lionio

    lionio Новичок

    Сообщения:
    7
    Симпатии:
    0
    Проблема была в том, что я раньше, в целях защиты от хакеров, переименовывал папку /admin

    Теперь новая сложность. В обоих установленных модулях, если править настройки или добавлять статью, то ничего не сохраняется. Ошибок никаких не выдает.

    Может опять дело в переименовании папки /admin ?
     
  11. Vlad

    Vlad Эксперт

    Сообщения:
    3.893
    Симпатии:
    937
    Ссылку на варезно-вирусный сайт удаляйте.
    Удаляйте все. Устанавливайте заново без модулей с вирусами.
    Потом обратно возвращайтесь с вопросами, если останутся.
     
  12. bokas

    bokas Новичок

    Сообщения:
    25
    Симпатии:
    0
    Добрый день! У меня та же пролема, но немного под другим углом. После установки все гуд, но я подключаю другую базу и после чего при входе в админку доступ ко всем разделам запрещен. Есть какое-то решение?
     
  13. Ecsiron

    Ecsiron Продвинутый пользователь

    Сообщения:
    415
    Симпатии:
    52
    А вот мне кажется, что в админке вы и не подключили, если она не загружается)
     
  14. bokas

    bokas Новичок

    Сообщения:
    25
    Симпатии:
    0
    Да нет вы не угадали, я же вхожу под своим паролем, но на все вкладках нет доступа. Есть какие то варианты еще ? версии играют роль? с 2.0.3.1 на 2.1...
     
  15. Ecsiron

    Ecsiron Продвинутый пользователь

    Сообщения:
    415
    Симпатии:
    52
    Тогда нужно было по порядку рассказывать, откуда вы взяли базу, которую подключили.
     
  16. bokas

    bokas Новичок

    Сообщения:
    25
    Симпатии:
    0
    Есть рабочий сайт. хочу попробовать новый шаблон, с рабочего сайта взял базу, накатил новый опенкарт. подключил базу. вхожу в админку чтобы включить новый шаблон, а оказывается доступа у меня то нет- )
     
  17. Ecsiron

    Ecsiron Продвинутый пользователь

    Сообщения:
    415
    Симпатии:
    52
    Версия сайта какая, походу базы не совместимые. Нужно произвести апдейт по базе.
    Это ситуация вообще уже склоняется к теме ищу исполнителя с такими ответами.
     
  18. bokas

    bokas Новичок

    Сообщения:
    25
    Симпатии:
    0
    база с 2.0.3.1 , ставлю на 2.1...
     
  19. Ecsiron

    Ecsiron Продвинутый пользователь

    Сообщения:
    415
    Симпатии:
    52
    Так и думал. Даже не знаю, что тут сказать и что еще посоветовать.
    Сер, правильнее будет, если Вы найдете индивидуального помощника.
     
  20. Zhezkazganetcs

    Zhezkazganetcs Продвинутый пользователь

    Сообщения:
    819
    Симпатии:
    107
    установить чистую 2.0.3.1
    обновить до 2,1
    накатывать шаблон