Риторический вопрос о шаблонах

Тема в разделе "Обо всём", создана пользователем Kuggel, 15 окт 2015.

  1. Kuggel

    Kuggel Новичок

    Сообщения:
    16
    Симпатии:
    0
    Здравствуйте, о Кулибины ) можно пофилософствовать с вами на тему данную?
    на ваш взгляд, что лучше сейчас купить шаблон или покупать модули и сайт делать самому с нуля?
    поскольку опыта в HTML и написания "кода" опыта нет вообще....
    какой у вас опыт был? Использовал несколько платных шаблонов, на последнем сейчас с его создателем думаем как привести его в божеский вид, но ответы как ни странно начали приходить все реже и реже. Поэтому задумался... может все напрасно и самому надо с нуля все читать или нанять грамотного человека и за плату что бы он сделал сайт? Склоняюсь все таки к первому варианту...
    так вот вопрос созрел... если начинать самому, то какую версию OSstore зять за основу? и какие базовые модули ставить на нее? кроме же модуля покупка в один клик, орфографии и экспорт и импорт, тоже что то ставить надо? Я прекрасно понимаю, что каждый идет своим путем, но все же... есть истины с коими не поспоришь...буду рад вашим ответам.
    С уважением,
     
  2. Vlad

    Vlad Эксперт

    Сообщения:
    3.869
    Симпатии:
    936
    вы видимо не по адресу )) Тут только опенкарт !!!
    Если у вас есть время и большое желание то делайте все сами.

    По мне так нет базовых, все ставится под задачи. Можно вообще не ставить ничего и прекрасно продавать..
     
  3. Kuggel

    Kuggel Новичок

    Сообщения:
    16
    Симпатии:
    0
    Спасибо, я имел в виду последнюю версию Опепкарт, будут ли под нее работать модули, или лучше скачать не такие ранние но и не поздние. или все равно?
     
  4. solunski.d

    solunski.d Эксперт

    Сообщения:
    1.565
    Симпатии:
    428
    Очень сложно понять о чем вы говорите.
    Но если я правильно вас понял, то.
    Если модуль, допустим ориентирован под версию 2.0.3.1, то версия движка должна быть соответствующей.
     
  5. Kuggel

    Kuggel Новичок

    Сообщения:
    16
    Симпатии:
    0
    да, именно про это..например модулей много для 1.5.5.1 или 2.0.3.1, то не стоит торопиться и ставить последнюю v 2.1.0.1 "Русская сборка"...
    а иностранные разработанные для 2.0.3.1. будут работать под такой же версией Русской сборки?
     
  6. solunski.d

    solunski.d Эксперт

    Сообщения:
    1.565
    Симпатии:
    428
    o_O Изначально выходит оригинал 2.1.0.1, затем, наши делают русскую сборку на такой же самой версии.
    Как говорил админ, это почти оригинальный движок, но с исправлением ошибок официалки + перевод + и небольшие дополнения, которые в очень редких случая, могут конфликтовать с другими модулями, лично у меня ни разу не было конфликтов.

    И то что версия движка 2.1.0.1, может практически ни чем не отличатся от 2.0.3.1, в версию движка 2.1.0.1 добавили пару модулей и не много изменили админку, в основном можно зайти на оригинальный сайт и посмотреть что они сделали в версии 2.1.0.1.
    И это значит что модуль созданный под версию 2.0.3.1 может спокойно работать и под 2.1.0.1.
     
    Romans нравится это.
  7. Kuggel

    Kuggel Новичок

    Сообщения:
    16
    Симпатии:
    0
    спасибо за разъяснения... попытаюсь что то, сотворить. пошел тренироваться на шаблонах.
     
  8. Romans

    Romans Administrator Команда форума

    Сообщения:
    1.337
    Симпатии:
    698
    Конфликт модулей или шаблонов между от версии2.0.3.1 при установке на 2.1.0.1 может быть в трех случаях.
    1. Окмод не нашел нужную строку в файле (например поставили дополнительную запятую)
    2. В 2.1.0.1 некоторые файлы движка перенесли в другое место, поэтому старый модуль не может подключить модель т.к она уже по другому пути.
    3. Что то еще .... надо смотреть.


    она отличается в плане переписанного кода, но концептуально ничего е изменилось и разработчики легким движением руки, могут спокойно подкорректировать модули под 2.1