Ошибка регистрации [версия неизвестна]

Тема в разделе "Ошибки и их решения", создана пользователем puza77, 1 июн 2015.

  1. puza77

    puza77 Новичок

    Сообщения:
    7
    Симпатии:
    0
    Проблема с регистрацией, при регистрации новому пользователю выдается следующая ошибка
    Notice: Error: E-Mail to required! in /var/www/vhosts/............./system/library/mail.php on line 61
     
  2. Ален

    Ален Эксперт

    Сообщения:
    2.055
    Симпатии:
    634
    А может вы ошиблись все же версией??? В 2.0.3.1 такого нет.
     
  3. puza77

    puza77 Новичок

    Сообщения:
    7
    Симпатии:
    0
    Нет, не ошибся
    Version 2.0.3.1 (trs.2.0.3.0)
     
  4. Ален

    Ален Эксперт

    Сообщения:
    2.055
    Симпатии:
    634
    Как то странно. У меня нет ошибки. Правда у меня тестируемаемая сборка, это Русская сборка и именно она тут и обсуждается, но все равно, не должно быть такой ошибки. Может у вас не чистая версия. Может какие дополнения установили, модули, что то правили итд.
     
  5. lavlan

    lavlan Пользователь

    Сообщения:
    89
    Симпатии:
    20
    Случайно у Вы не эту сборку поставили?
    Мы с радостью сообщаем о выходе новой версии OCSHOP.CMS 2.0.3.1
    просто в admin/language/common/footer.php есть вот такая строка...

    $_['text_version'] = 'Version %s (rs.1)';
     
    Последнее редактирование: 1 июн 2015
  6. Ален

    Ален Эксперт

    Сообщения:
    2.055
    Симпатии:
    634
    у него перевод просто от русской сборки. И движок может новый. Но может установлены модули, которые и поломали работу.
    В любом случаи нужны мельчайшие подробности, что да как.

    У вас все норм в русской сборке 2.0.3.1 ?? И не надо рекламировать чужое ;)
     
  7. puza77

    puza77 Новичок

    Сообщения:
    7
    Симпатии:
    0
    На самом деле я изначально установил с Вашего сайта версию 2.0.2, в последствии было два обновления, но проблема эта была изначально.
     
  8. Romans

    Romans Administrator Команда форума

    Сообщения:
    1.342
    Симпатии:
    702
    Значит обновили неправильно, криво итд итп. Выше указанная ошибка была только на 2.0.2.0, поэтому могу порекомендовать обновится "нормально", с заменой всех файлов.
     
  9. puza77

    puza77 Новичок

    Сообщения:
    7
    Симпатии:
    0
    Так нормально обновился :(
     
  10. Romans

    Romans Administrator Команда форума

    Сообщения:
    1.342
    Симпатии:
    702
    Zlata Jesen нравится это.
  11. Ален

    Ален Эксперт

    Сообщения:
    2.055
    Симпатии:
    634
    установи движок заново и сделай импорт базы. Все будет работать.
     
  12. ansar15

    ansar15 Новичок

    Сообщения:
    2
    Симпатии:
    0
    Привет всем!
    Люди добрые помогите уже третий день мучаюсь!!!!!!!!!!!!!!!!
    При регистрации нового клиента выдает вот такую ошибку.
    Opencart 2.0.0

    Notice: Error: Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation 'concat'
    Error No: 1267
    SELECT * FROM oc_customer WHERE LOWER(email) = 'хххххххххххх' AND (password = SHA1(CONCAT(salt, SHA1(CONCAT(salt, SHA1('ххххххх'))))) OR password = 'e6a52c828d56b46129fbf85c4cd164b3') AND status = '1' AND approved = '1' in /customers/0/a/d/designsten.com/httpd.www/system/library/db/mysqli.php on line 40Notice: Trying to get property of non-object in /customers/0/a/d/designsten.com/httpd.www/system/library/customer.php on line 53Warning: Cannot modify header information - headers already sent by (output started at /customers/0/a/d/designsten.com/httpd.www/index.php:98) in /customers/0/a/d/designsten.com/httpd.www/system/library/response.php on line 12

    И еще ранние зарегистрированные пользователи тоже не могут войти.
    Для них выдает вот такую ошибку.

    Notice: Error: Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation 'concat'
    Error No: 1267
    SELECT * FROM oc_customer WHERE LOWER(email) = 'ххххххххххххх' AND (password = SHA1(CONCAT(salt, SHA1(CONCAT(salt, SHA1('ххххххххххх'))))) OR password = 'e6a52c828d56b46129fbf85c4cd164b3') AND status = '1' AND approved = '1' in /customers/0/a/d/designsten.com/httpd.www/system/library/db/mysqli.php on line 40Notice: Trying to get property of non-object in /customers/0/a/d/designsten.com/httpd.www/system
     
  13. Vlad

    Vlad Эксперт

    Сообщения:
    3.930
    Симпатии:
    941
    Вообще то текущая версия это 2.3 )) Как то старовата у вас версия для решения проблем.
     
  14. ansar15

    ansar15 Новичок

    Сообщения:
    2
    Симпатии:
    0
    это из за того-что сайт на шведском языке а модули не очень богаты на этот язык, так что обновляться нет смысла
     
  15. Vlad

    Vlad Эксперт

    Сообщения:
    3.930
    Симпатии:
    941
    уж перевести пару строк в языковом файле не так уж трудно.