Ошибка пр установке ocstore 3

Тема в разделе "Установка и обновление", создана пользователем Genri, 20 ноя 2023.

  1. Genri

    Genri Пользователь

    Сообщения:
    43
    Симпатии:
    0
    Вот такое сообщение весит и как от него избавится ? Не совсем понимаю как это поменять.

    : использование класса «Twig_Loader_Array» устарело, начиная с версии Twig 2.7, вместо этого используйте «Twig\Loader\ArrayLoader». в /var/www/u2314370/data/www/storage/vendor/twig/twig/lib/Twig/Loader/Array.php в строке 7. Неизвестно : использование класса «Twig_Loader_Filesystem» устарело, начиная с версии Twig 2.7, используйте «Twig». Вместо этого \Loader\FilesystemLoader. в /var/www/u2314370/data/www/storage/vendor/twig/twig/lib/Twig/Loader/Filesystem.php в строке 7. Неизвестно : использование класса «Twig_Loader_Chain» устарело, начиная с версии Twig 2.7, используйте «Twig». Вместо этого \Loader\ChainLoader. в /var/www/u2314370/data/www/storage/vendor/twig/twig/lib/Twig/Loader/Chain.php в строке 7
     
  2. Tom

    Tom Специалист

    Сообщения:
    740
    Симпатии:
    239
    Не нужно переводить ошибки на русский.
    Версия php какая? Для Ocstore 3.0.3.7 оптимальный вариант это 7.3-7.4, на восьмой версии не работает.
     
  3. Genri

    Genri Пользователь

    Сообщения:
    43
    Симпатии:
    0
    Вы правы были, сменил на 7.4 все заработало сразу. Странно что они застряли на этой версии и не растут.
     
  4. Tom

    Tom Специалист

    Сообщения:
    740
    Симпатии:
    239
    Застрял сам опенкарт. Но уже вышел релиз 3.0.3.9, так же на лайве идёт адаптация и Ocstore под эту версию. Пока правда не рекомендую ставить на рабочие проекты.
    Да и у версии масса нюансов. Хорошо иметь такую сборку. Но масса модулей просто не поддерживают 8.