Обновление 2.0 -> 2.0.1.0

Тема в разделе "Установка и обновление", создана пользователем 6yka, 5 дек 2014.

  1. 6yka

    6yka Пользователь

    Сообщения:
    37
    Симпатии:
    1
    Господа,

    подскажите, плз. У меня уже установлена оригинальная 2.0
    Что мне нужно залить, чтобы обновиться до русской 2.0.1.0 версии? или нужно все заново ставить?
    спасибо
     
  2. Romans

    Romans Administrator Команда форума

    Сообщения:
    1.337
    Симпатии:
    698
    Лучше думаю сделать так.

    Если есть уже товары и категории.
    1. Сохранить через phpmyadmin или прямо через админку (меню-инструменты-бекап) все таблицы начинающиеся на oc_product**** oc_category****
    2. Затем удалить магазин, очистить базу и установить все по новой.
    3. Далее просто восстанавливаем таблицы oc_product**** oc_category****
    Если были атрибуты и опции то соответственно oc_attribute*** и oc_option**

    Вот и все!

    P.S Желательно перед всеми действиями сделать полный бекап базы через phpmyadmin

    Если ничего особого нет, то просто устанавливаем заново.
     
  3. 6yka

    6yka Пользователь

    Сообщения:
    37
    Симпатии:
    1
    спасибо, попробую.
    отпишу по результату
     
  4. Graund

    Graund Новичок

    Сообщения:
    10
    Симпатии:
    2
    А такой вопрос, можно ли с 1.5.5.1 сохранить таблицы и какие, и вставить в 2.0.1.1?
     
  5. Romans

    Romans Administrator Команда форума

    Сообщения:
    1.337
    Симпатии:
    698
    думаю те же самые для товаров. По хорошему надо провести эксперимент... пока руки не дошли.
     
  6. nikorn

    nikorn Новичок

    Сообщения:
    1
    Симпатии:
    0
    В дальнейшем при выходе новых версий (оригинальных и "русских сборок"):
    1) Чтобы обновить версию "Русской сборки" на более новую достаточно будет залить новые файлы или придется так же сохранять данные, а потом втягивать их в базу?
    2) Если установить новую версию оригинального OpenCart поверх старой версии "Русской сборки", то все "поплывет"?
     
  7. Romans

    Romans Administrator Команда форума

    Сообщения:
    1.337
    Симпатии:
    698
    @nikorn
    1. При выходе русских сборок, достаточно перезаписать файлы. Если необходимо будет что то добавлять в базу, я буду сообщать отдельно.
    2. Не поплывет. Пропадет как минимум русский редактор, правильное ЧПУ, скрытие полей в карточке товара, и какие нибудь исправления, которые я делаю для лучшей работы..
     
  8. Graund

    Graund Новичок

    Сообщения:
    10
    Симпатии:
    2
    Поплывут модули не поддерживающие новую версию
     
  9. Romans

    Romans Administrator Команда форума

    Сообщения:
    1.337
    Симпатии:
    698
    да, что то я призадумался. А старая у вас какая? Или Вы хотите перейти с 1.5.6.1 на 2х то естественно все поплывет и не только.

    Господа. Указывайте в вопросе пожалуйста точную версию. А то для меня "старая" это просто предыдущий релиз, а не старая ветка 1.5х